Forums Home | FAQ | Search  
Forums > iGetter for Windows
Erorr 401 for FTP
< Last Thread     Next Thread >
Author
Thread    Post New Thread     Post A Reply

10-25-2009 06:20 AM

Posted by:
THEAST

Find more posts by THEAST

Hi all. I use igetter on windows and I love this app but there is a big problem that I can't get rid of, no matter what I do. Whenever I want to download sth from an FTP that needs authentication, I get "Network error: 401" while I have already entered the id and pass and they're both right. Considering the fact that I have the same problem while trying to open such FTPs with Opera, I think it might be a problem with the network at my uni but the exact same procedure works properly with both Firefox and IDM. So I'm wondering, why can IDM download the file (even if there is sth wrong with the network) and igetter can't? Is there a way to fx this problem?
P.S. FTPs that don't need authentication work properly with igetter and the problem is only with FTPs that need authentication.

10-27-2009 05:37 PM

Posted by:
iGetter Support

Find more posts by iGetter Support

THEAST,
Since you have not posted any URL for testing, I can't tell you what may have caused the problem. However, there are some FTP servers (i.e. wu-ftpd server) that don't count the current user directory as a root directory and this may cause a file not found error or authentication error. The problem is that the URL should include also the user folder where the file is located. For example if you want to download:
ftp://user:password@ftp1.site.com/file.zip

Modify it to:
ftp://user:password@ftp1.site.com/user/file.zip

Another way to avoid such problems is to add the file for downloading using the iGetter Site Explorer feature. Also, you can enter your user info in the iGetter options (menu Tools), Site Manager panel.

Regards,
iGetter Support

10-28-2009 06:44 AM

Posted by:
THEAST

Find more posts by THEAST

Thanks for the reply, but unfortunately, the FTP I'm refering to is a private FTP and I can't post the link here. And as I said, I cannot get in any FTPs that need authentication. Funny thing is, the exact same link works perfectly when I try it with igetter at home but it doesn't work with the exact same version of igetter at my university and also doesn't work in opera browser and many other download managers. The only browser that works with FTPs that need authentication is firefox and the only download managers I have found that work are IDM and DAP. Now I'm nearly sure the problem is from my network (and I can't go to the admin of my network for so many reasons) but I'm still wondering why igetter can't be one of the download managers that work?
I'm sure that the id & pass are not even sent cause I also tried downloading the index of the FTP and I got the same error. I also tried the site explorer, I was again and again asked to enter the id & pass which I think means the authentication has failed.
And here's igetter's log for the sake of completeness:

---- Start request: 10/28/2009 12:26:58 PM
Connecting to: xxxxxxx via HTTP proxy 194.225.33.254:8080
GET ftp://xxxxxxx/ HTTP/1.0
Host: xxxxxxx
User-Agent: iGetter/2.0
Authorization: Basic xxxxxxxxxxxxxx
Range: bytes=0-
Accept: */*
Pragma: no-cache

HTTP/1.1 401 Unauthorized
Via: 1.0 ALBORZ
Connection: close
Content-Length: 1217
Expires: Wed, 28 Oct 2009 09:07:51 GMT
Date: Wed, 28 Oct 2009 09:07:51 GMT
Content-Type: text/html
Server: squid
X-Squid-Error: ERR_FTP_FORBIDDEN 0
X-Cache: MISS from CASPIAN.Advanced.Corporate.Traffic.Manager.v1.4
X-Cache-Lookup: MISS from CASPIAN.Advanced.Corporate.Traffic.Manager.v1.4:3128
X-Cache: MISS from Main.Cache.of.Kharazmi
X-Cache: MISS from Main.Proxy.of.Kharazmi
Network error: 401

10-28-2009 02:52 PM

Posted by:
iGetter Support

Find more posts by iGetter Support

THEAST,
It seems that you are trying to download an FTP file through HTTP proxy. iGetter supports this if the HTTP and FTP proxies use the same port. Now, it seems that the squid server returns ERR_FTP_FORBIDDEN error which means one of the following three things: 1.) The proxy server requires Proxy-Authorization; 2.) The proxy server should work with the CONNECT instead of GET method; 3.) squid blocks FTP for some other reason.

What you may try:
1. If the proxy requires password enter it in the iGetter options, Proxy panel, Advanced button. Enter your user info for the HTTP proxy.
2. Turn off HTTP and FTP proxies, but turn on the HTTPS proxy. This way iGetter will use the CONNECT method and the proxy will act as tunnel on the same port.

Finally you may see what method Firefox uses if you install the Live HTTP Headers add-on http://livehttpheaders.mozdev.org/.

Regards,
iGetter Support

11-08-2009 05:27 AM

Posted by:
THEAST

Find more posts by THEAST

Hello again and sorry for the delay.
The proxy I use is the network proxy at my uni, so normally the port for all the connections should be the same, right?
I tried entering the ID & Pass I use to log in the clients at the internet center for all the protocols, still I get the 401 error. I also tried the second method you mentioned, I got error 502, here's the log:


---- Start request: 11/7/2009 2:14:32 PM
Connecting to: XXXXXXXXXXXXXXXXXXX via TUNNEL proxy 194.225.33.254:8080
CONNECT XXXXXXXXXXXXXXXXXX:21 HTTP/1.0
Proxy-Authorization: Basic XXXXXXXXXXXXXXXXXX

HTTP/1.1 502 Proxy Error ( The specified Secure Sockets Layer (SSL) port is not allowed. ISA Server is not configured to allow SSL requests from this port. Most Web browsers use port 443 for SSL requests. )
Via: 1.1 ALBORZ
Connection: close
Proxy-Connection: close
Pragma: no-cache
Cache-Control: no-cache
Content-Type: text/html
Content-Length: 774

Network error: 502


++++ Status: Segment paused by user. ++++



Then I installed the firefox add-on you mentioned and successfully logged in the FTP, here's the log:


GET /data/ HTTP/1.1
Host: XXXXXXXXXXXXXXXXXXXXXXX
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Proxy-Connection: keep-alive

HTTP/1.x 200 OK
Via: 1.0 ALBORZ
Connection: close
Proxy-Connection: close
Date: Sat, 07 Nov 2009 10:43:43 GMT
Content-Type: text/html
Server: squid
X-Cache: MISS from CASPIAN.Advanced.Corporate.Traffic.Manager.v1.4, MISS from Main.Cache.of.Kharazmi, MISS from Main.Proxy.of.Kharazmi
X-Cache-Lookup: MISS from CASPIAN.Advanced.Corporate.Traffic.Manager.v1.4:3128

I think that's the only important part, right? The log is so long so I only posted the first part, if needed, I'll also post the rest.
And really thanks for the great support, I couldn't even imagine igetter might have such good support!:)

11-10-2009 06:19 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

It seems that Firefox doesn't send any authentication info so you may try the following with iGetter:
1. Clear all user info from the Proxy authentication dialog as well as download authentication (at "Item Settings" dialog) including the Site Manager entries for that ftp site.
2. You may change the "HTTP user agent" entry to Firefox at iGetter Options, Advanced panel.

Regards,
iGetter Support

All times are CT (US)    Post New Thread     Post A Reply
Forum Jump:
< Last Thread     Next Thread >



| Home | News | iGetter | Downloads | Forums |

| Privacy Policy | Contact us |

All contents of these forums are copyright © 2001-2016 Presenta Ltd. All rights reserved.
Forums are moderated by Presenta Ltd.

Powered by: vBulletin Lite Version 1.0.0 Lite
Copyright © Jelsoft Enterprises Limited 2000.