Forums Home | FAQ | Search  
Forums > iGetter for Mac OS X
new iGetter
< Last Thread     Next Thread >
Author
Thread    Post New Thread     Post A Reply

05-19-2011 06:42 PM

Posted by:
Joe

Find more posts by Joe

I recently got a new iGetter (new serial number). I have used this program for some time in the past. I also installed a new Foxfire. I visually copied all of the preference on iGetter from the old one. I have never linked it to the browser. I do all downloading from the clipboard using RS and Megaupload.

When I copy the clipboard to iGetter in the "pause all" function, then clic "start auto", all of the file appear for seconds, and do not download. Just the image of the files appears in the download folder. I looked at the RS and Megaupload premium account pages, and they have the same preferences.

I can't figure what I am doing wrong. Please help.

05-20-2011 07:26 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello Joe,
The reported problem may occur if RS or Megaupload don't receive required authentication. Most probably the small file that disappears from the queue is an html page that shows some error (authentication error, busy server, etc). To see that error, select some of the downloaded small files in the iGetter History list. Double click on one of them to locate the physical file (or use the "Reveal in Finder" contextual menu command). Rename it adding an ".html" extension. Next open it in your browser and see if there is some useful info about the problem.

What you can try:
1. Use only your default browser when you add such links to iGetter. You can set it at Safari preferences, General Panel -> "Default Web browser". Here you can choose Firefox for example if you use it instead of Safari.
2. Login to your premium area in your default browser. If there is a "Remember me" option when you login turn it on. This step may set an authentication cookie that iGetter will read after that.

3. In your rapidshare premium area, turn on direct downloads option and turn off SSL option (My RapidShare->File Manager->Download Settings:
Direct Downloads->ON
Secure Downloads (SSL)->OFF

4. Enter RS and Megaupload with your user info in iGetter preferences, Site Manager panel (notice the point before rapidshare.com):

http://.rapidshare.com/
http://.rapidshare.de/
http://.megaupload.com/

5. If you use Firefox you can install the FlashGot add-on (https://addons.mozilla.org/en-US/firefox/addon/220/). Then use the FlashGot contextual menu commands or click on a link and when the Firefox save dialog appears choose iGetter. These two functions support session cookies.

Regards,
iGetter Support

05-20-2011 05:04 PM

Posted by:
Joe

Find more posts by Joe

I have tried everything you said. I wrote RS, who says SSL cannot be turned off anymore. But, keep in mind, I have iGetter on another computer on this same address, now operating in "trial" mode, and it works fine. The one on this computer is the one I paid for. You then turned that older serial off. It works fine! (in the trial mode). This one, which is a full iGetter, still does not work. Both are linked to the same exact RS and Megaupload addresses (and their preferences have not changed). I also set up Foxfire identically in both computers.

I downloaded FlashGot, and this did not help. Somehow, I did not have these problems in the past (I am an experienced user). I have spent hours trying to get this to work, and have followed your instructions carefully. I feel like giving up. Please help!

05-21-2011 06:07 PM

Posted by:
Joe

Find more posts by Joe

I did discover the problem by accident: iGetter is not compatible with Firefox 4. I wish I knew that before the hours of work.

05-23-2011 06:51 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello Joe,
iGetter registration doesn't add any functionality, so the problem is somewhere in the authentication process. If you have a machine where the same RS link works, then problem could be easily resolved. As of iGetter add-on for Firefox 4, indeed it's currently incompatible, but FlashGot add-on completely covers all CM commands. Their names are "FlashGot Link", "FlashGot Selection" and "FlashGot all". It also supports session cookies required from some sites.

To resolve the problem, go to your working copy of iGetter and start some RS link. If the download starts successfully, pause it and open "Item Settings" dialog, Advanced panel. Now, make a screenshot if you want, but you should compare these options with your other copy of iGetter. To do so, in your other copy of iGetter, turn on "Open save dialog on new download" option at iGetter preferences, General panel. Then add the same RS link (using the same method/browser). Now compare all fields in the Item Settings, Advanced panel. All options must appear exactly the same as your working copy of iGetter. User name & password should not be empty, Referrer, User-Agent and Cookie options must be the same. If something is different, then you have turned some option off (i.e. "Send cookies from browser" option at iGetter preferences, Integration panel).

You may also add "https://.rapidshare.com/" in the iGetter Site Manager to authenticate SSL links.

Regards,
iGetter Support

All times are CT (US)    Post New Thread     Post A Reply
Forum Jump:
< Last Thread     Next Thread >



| Home | News | iGetter | Downloads | Forums |

| Privacy Policy | Contact us |

All contents of these forums are copyright © 2001-2016 Presenta Ltd. All rights reserved.
Forums are moderated by Presenta Ltd.

Powered by: vBulletin Lite Version 1.0.0 Lite
Copyright © Jelsoft Enterprises Limited 2000.