Forums Home | FAQ | Search  
Forums > iGetter for Mac OS X
iGetter and Protected Directories
< Last Thread     Next Thread >
Author
Thread    Post New Thread     Post A Reply

06-19-2011 04:30 AM

Posted by:
Alex

Find more posts by Alex

I am running the 2.8.7 version of iGetter on 10.6.7 and have never had issues till the latest update.

I access a .htaccess protected directory where all my files are either in the root or nested inside other folders. Currently, I am able to authenticate and download any file in the root but as soon as the application tries to fetch data from a directory one level down (eg; root/IMPORTANT_FILES_I_NEED_NOW) the file status changes between connecting and waiting...

I have tried updating the sever/path under site manager to reflect the directory the file resides in but still it has no effect.

This is most frustrating and am having to resort to other applications to pull the files down.

Any ideas...

06-20-2011 02:42 PM

Posted by:
iGetter Support

Find more posts by iGetter Support

Alex,
We just tested iGetter v2.8.7 with two sub directories with .htaccess and it works fine. You may try this:
1. Remove all entries for that site from the Site Manager panel.
2. Use the "New URL" dialog, Advanced panel to enter your user info and check "Apply these Settings to Site Manager" option. This way you will add proper server paths to Site Manager.
3. If this problem appeared only in v2.8.7, turn on "Save redirected URLs" option at iGetter preferences, Advanced panel.

If the problem persists, please, send to us some URLs and user info that may reproduce the problem using our support form: http://presenta.net/igetterfeedback.html

Thanks,
iGetter Support

06-23-2011 08:44 AM

Posted by:
Alex

Find more posts by Alex

Hi,

So if I perform step 2, the download completes normally. This is a bit of a problem though as not only is my password over 14 characters, it's random and typing it in along with user info every time I wish to download outside of the root is very annoying. As a result, I download over hundreds of individual files daily over probably 80+ URL's. Adding this information manually to each file takes precious time that I can't afford to be spending when it originally worked perfectly...

Strangely, this problem is now apparent in the previous version I rolled back to.

Due to security, I just can't hand over url's and authentication to you obviously but this problem is not replicated in other similar download managment applications, only iGetter has issues outside the root directory.

Is there anything else I can do on my end or do you absolutely need to get access? I really need to fix this problem. Thanks!

06-23-2011 05:24 PM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello Alex,
So, after you have turned on "Apply these Settings to Site Manager" option in "New URL" dialog, did you see that server and exact path (path should end with slash /) in iGetter preferences, Site Manager panel?

If iGetter finds an entry in the Site Manager, when you add an URL and select Advanced panel of "New URL" dialog, user info should be prefilled.

If the sub-domains of URLs are different (like www1.server.com, www2.server.com), you need to add a site entry like this "http://.server.com/path/".

We need some steps to reproduce the problem. So an example .htaccess file with the same server configuration is welcome. We tested with AuthType Basic, "AuthUserFile ...", "Require user ..." in the "Directory" directive of the conf file for two sub-directories and iGetter worked fine.

Thanks,
iGetter Support

06-23-2011 10:16 PM

Posted by:
Alex

Find more posts by Alex

So, after you have turned on "Apply these Settings to Site Manager" option in "New URL" dialog, did you see that server and exact path (path should end with slash /) in iGetter preferences, Site Manager panel?

- Yes, The exact path is now visible for each directory that had the apply option enabled.

If iGetter finds an entry in the Site Manager, when you add an URL and select Advanced panel of "New URL" dialog, user info should be prefilled.

- Yeah, I already knew this but as there is only ever one file inside each directory, it doesn't help me at all. I don't understand why iGetter needs to authenticate again to go down a directory.

If the sub-domains of URLs are different (like www1.server.com, www2.server.com), you need to add a site entry like this "http://.server.com/path/".

- Same URL.

We need some steps to reproduce the problem. So an example .htaccess file with the same server configuration is welcome. We tested with AuthType Basic, "AuthUserFile ...", "Require user ..." in the "Directory" directive of the conf file for two sub-directories and iGetter worked fine.

- AuthType Basic is the authentication. I'll try and get a .htaccess file to you. Where do I send it? My email is on the first post.

06-24-2011 05:06 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello Alex,
After testing a while I think that the only site entry that you need to enter should be without any path like this "http://www.site.com/" or if you want all sub-domains included like this "http://.site.com/". If you add a path iGetter will authenticate only files in the exact path not sub-paths.

In other words "http://www.site.com/path/" will not authenticate "http://www.site.com/path/subpath/file.dmg", but "http://www.site.com/" will authenticate files in both "path" and "path/subpath" directories.

You can send an example .htaccess file to:

Thanks,
iGetter Support

All times are CT (US)    Post New Thread     Post A Reply
Forum Jump:
< Last Thread     Next Thread >



| Home | News | iGetter | Downloads | Forums |

| Privacy Policy | Contact us |

All contents of these forums are copyright © 2001-2016 Presenta Ltd. All rights reserved.
Forums are moderated by Presenta Ltd.

Powered by: vBulletin Lite Version 1.0.0 Lite
Copyright © Jelsoft Enterprises Limited 2000.