Forums Home | FAQ | Search  
Forums > iGetter for Mac OS X
Broken downloads won't resume
< Last Thread     Next Thread >
Author
Thread    Post New Thread     Post A Reply

01-03-2013 08:02 PM

Posted by:
Francis

Find more posts by Francis

I downloaded iGetter for Mac OS to download .mp4 video files from a XXX paysite. After about a week of great, fast, uninterrupted downloads, I am getting a lot of broken downloads, specifically about 9 out of 10 attempts. I only have 1 file downloading at a time, and have plenty of hard drive space available, etc. It will not let me resume these downloads, and they usually cut off right around 1900 MB. Is there any fix for this? I'm not downloading from a file sharing site, so there is no alternate download address for the files. Thanks, I really like iGetter and would like to get it working right again, I'm not sure why it was working, but now does not.

01-04-2013 01:16 AM

Posted by:
Francis

Find more posts by Francis

for instance: 2266 of 2361 MB downloaded, Status alternates between "Waiting" and "Connecting", tries to Resume 155 times, becomes Broken. Cannot restore. ????

01-04-2013 12:49 PM

Posted by:
Francis

Find more posts by Francis

would it solve the problem if I paid for a registered version of iGetter? Have I reached the maximum of downloads on the free version? I definitely think it's the program, not my internet connection/OS etc....

01-04-2013 05:09 PM

Posted by:
iGetter Support

Find more posts by iGetter Support

Most probably the problem is caused by an expired URL or a network error. In example if you reach some server limit it will reject any new connections for a given time. To see the exact error select the waiting/broken download in iGetter and then select Segments tab panel.

What you may try:
1. Set "Minimal segment size" value at iGetter preferences, Acceleration panel, to 50 000 KB. This way iGetter will not try to make new connections at least 50MB from end of the file.

2. Verify that these options are ON: "Save redirected URLs" (at iGetter preferences, Advanced panel) and "Send cookies from browser" (Integration panel).

3. Find the same download link on the site and copy it. Then find the broken download in iGetter (pause it, if it's running) and double click on it to open "Item Settings" dialog. Now replace the existing URL with the one copied from the site. Confirm and start the download in iGetter.

We can be of a better help if you post an example URL, web page, etc. where we can reproduce the problem.

Regards,
iGetter Support

01-04-2013 11:46 PM

Posted by:
Francis

Find more posts by Francis

Thanks for the response.

Here is the log of the final attempt to connect to download - at 2295 of 2361 MB downloaded. Downloads freeze every time at this point, about 98% through. I've restarted, tried a different browser, followed your exact preferences, and tried to copy URL/restart, to no avail.

- is this a bug, should I reinstall iGetter?

-would it be an incompatibility between iGetter and older versions of MacOS/Firefox/Google Chrome?

-would paying for a liscence make iGetter run right?

I used it for a week, steadily with no issues, and suddnely it has this download issue.

here is the log:



---- Start request: 1/4/13 9:27:37 PM

Connecting to: dl01.julesjordan.com

GET /dl/7e0db4ad868ad9b72afb121861f8292d/50e7a16a/members/content/upload/julesjordan/lex_the_impaler_7_scene1/mp48000/lex_the_impaler_7_scene_1_1080.mp4 HTTP/1.0
Host: dl01.julesjordan.com
User-Agent: iGetter/2 (Macintosh; U; PPC Mac OS X; en)
Referer: http://www.julesjordan.com/members/gallery.php?id=194&type=vids&
Range: bytes=755810304-
Accept: */*
Pragma: no-cache
Cookie: __utma=13798952.134961761.1357354971.1357354971.1357354971.1; __utmc=13798952; __utmz=13798952.1357354971.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); pcah=L0NBc1VGMlo3eFRNSUVEbWpWMGRZcUxRaXcyanpXOUYK; pcar%5fTWVtYmVycyBPbmx5=YzBIZDNkemVjNGp2NW5TZUxFTSt4U1BIU3ZIc3NuTWVYdEE2eWtraGJpK1U5WFdmRUkrRkRRPT0K

HTTP/1.0 410 Gone
Content-Type: text/html
Content-Length: 335
Connection: close
Date: Sat, 05 Jan 2013 05:27:55 GMT
Server: lighttpd

Network error: 410 HTTP/1.0 410 Gone

01-05-2013 01:25 AM

Posted by:
Francis

Find more posts by Francis

OK, now this is strange. My files are freezing at the end of the download, as above. But, if I try to restart the download, and iGetter marks it "Broken", the file seems to have finished downloading.

What it seems to be is a failure to completely "finish" the download, and move onto the next download. Whenever I queue up a couple files, they all break after the first one breaks. Initially, iGetter could handle a queue, but not now..... EXPLAIN???

01-08-2013 09:38 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

First, you can get full explanation from site owners (in your case julesjordan(dot)com) why they return "410 Gone" response at all. Here is what "HTTP/1.0 410 Gone" error means: "The requested resource is no longer available at the server and no forwarding address is known. The 410 response is primarily intended to assist the task of web maintenance by notifying the recipient that the resource is intentionally unavailable and that the server owners desire that remote links to that resource be removed."

Since you download very large files you may increase the "Minimal segment size" value at iGetter preferences, Acceleration panel, to 200 000 KB. This way iGetter will not try to make new connections at least 200MB from end of the file.

Next, try some downloads from the Apple support site and see if the problem persists: http://support.apple.com/downloads/

All times are CT (US)    Post New Thread     Post A Reply
Forum Jump:
< Last Thread     Next Thread >



| Home | News | iGetter | Downloads | Forums |

| Privacy Policy | Contact us |

All contents of these forums are copyright © 2001-2016 Presenta Ltd. All rights reserved.
Forums are moderated by Presenta Ltd.

Powered by: vBulletin Lite Version 1.0.0 Lite
Copyright © Jelsoft Enterprises Limited 2000.