Forums Home | FAQ | Search  
Forums > iGetter for Mac OS X
Extreme lag
< Last Thread     Next Thread >
Author
Thread    Post New Thread     Post A Reply

02-23-2005 10:15 AM

Posted by:
mr chuffy

Find more posts by mr chuffy

Igetter is extremely slow in rendering its GUI with a large queue set to auto download. If it is hidden in the finder then brought to the front again there is a noticable delay in displaying the main window. The spinning beachball is a common occurrence when attempting to do anything, access to the menus is very laggy. All in all it seems to be very memory hungry. I have a very well maintained mac and 1.2Gb of ram.

02-25-2005 05:36 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello,
The reported iGetter behavior may occur only if you have started multiple simultaneous downloads with 5 or more segments for each download. Number of segments multiplied by the number of downloads is equal to more CPU and memory consumption. Especially if you have set your connection type to DSL or better. To avoid such resource consumption, first, verify that you have set the "Max Auto Downloads" option (General panel preferences) to 3-4 and "Default number of segments" option (Acceleration panel preferences) to 3. iGetter will download faster and use less resources if you set it to download less simultaneous downloads.

Also, make sure that you use iGetter version 2.0 or later. Versions prior to v2.0 use more CPU and memory resources than v2.

Regards,
iGetter Support

03-16-2005 02:13 PM

Posted by:

Find more posts by

Igetter does what i describe if im queuing multiple downloads, ie downloading them one at a time. max auto downloads is set to 1, segments set to 3 and its version 2.1.

the extreme lag renders igetter almost unusable. eg, if i hide it as its downloading automatically and then attempt to bring it to the front again it takes an inordinate amount of time to display the main window. this does not occur when not downloading. my Sawtooth 450 G4 is setup perfectly, has the latest Panther patches and has 1.2Gb memory.

Lag is not evident using older igetter on os9 on same machine, different HD.

03-17-2005 06:49 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello,
This is the first and only report of such kind as well as we have never experienced slow window rendering of iGetter on our machines. The only thing that we may recommend you is to see if you use some third party haxie such as Application Enhancer of Unsanity. It may cause problems with iGetter rendering.

It seems that the problem is not in the download engine, but in rendering of windows on your machine. You may try v1.9.5 of iGetter http://www.fileavenue.com/downloads/iGetter1.9.5_En.dmg.bin and see if it will make a difference. Versions prior to 2.0 use less standard Apple controls as toolbar and data grid.

Regards,
iGetter Support

04-07-2005 12:14 PM

Posted by:

Find more posts by

I run no haxies such as you describe which 'enhance' the gui. The only thing i do use is tinker-tool interface speed up stuff like turn off zooming, bouncing and all that silly apple stuff. i recently uninstalled igetter and searched for leftover prefs etc, then reinstalled latest version. its improved matters but not entirely. eg, if i attempt to stop auto downloading while downloads are queued and running, igetter takes a long time to respond to mouse input, if at all!

04-11-2005 06:05 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello Mr. Chuffy,
We haven't tried iGetter with the Bresink's TinkerTool, but it seems that TinkerTool interacts too much with the Finder and may cause some problem in iGetter. Did you try to disable TinkerTool and test iGetter?

If the problem persists we recommend you v1.9.5 of iGetter. This version uses less standard Apple controls and may be it will run correctly on your 450 MHz Sawtooth machine.

Regards,
iGetter Support

06-18-2005 10:14 AM

Posted by:
chris

Find more posts by chris

interface lag

I've just upgraded to 2.3 and I've got the same problem.
I'm using a dual 800 G4 with 1GB ram and OS 10.3.9 with all the latest upgrades. I don't use any customising software, the OS is as Apple intended. IGetter 1.9.5 and 2 worked fine but 2.3 is very slow and unresponsive. When using auto downloading I can't add to the list while it's running (just get the beachball) The progress bars don't update at all and the status info at the bottom of the screen doesn't update. If I want to pause or stop auto downloading I have to force quit the program as it doesn't respond to clicks. Even though it doesn't show any thing it IS downloading, I can find the files afterwards. The download speed is very slow never higher than 10kb/s. I know it depends on the servers but the old versions were ALOT faster (5-7 times faster) As a test I've tried browsing in Explorer at the same time. In the previous versions this would be slow because IGetter would be hogging the bandwidth, but in 2.3 simultanious browsing is as fast as it should be( no problem with the connections) It doesn't seem as if IGetter is grabbing the bandwidth it should, even if nothing else is sharing with it. As a further test I set IGetter to download a 1 mb file and then after it had started downloaded the same file through Explorer. Explorer did it about five times faster than IGetter with a headstart!
I would go back to version 2 but I can't seem to get rid of 2.3. I run the uninstaller then drag 2 over but when I start it up it's still 2.3!! Help!

06-27-2005 07:47 AM

Posted by:
iGetter Support

Find more posts by iGetter Support

Hello Chris,
First, make sure that you have not set on the "Obey Speed Limit" option at menu Downloads. Next, look at the iGetter preferences, Acceleration panel, and set a proper connection type (it seems that you use a DSL or similar connection). You may set the default number of segments to 3 as well. Then, try to set the "Max simultaneous downloads" option (General panel) to 1. If the problem persist contact us at igettersupport(at)presenta.net with more information about your connection type, the number of downloads in your queue and an example URL.

We are testing iGetter v2.3 on a similar machine and it works pretty well. So, we must reproduce the problem first.

Regards,
iGetter Support

06-23-2006 06:14 PM

Posted by:
Chris

Find more posts by Chris

extreme lag and unresponsiveness

Hi, I've now managed to fix the problem I had- I had been using Igetter versions upto 2 with no problem but had installed the new upgrade which did n't work at all well, it's download speed was very slow and it was very unresponsive- I usually had to force quit Igetter to get it to stop.here's how I fixed my system:- I ran the uninstaller and then searched for Igetter files on my computer. I found six or seven and deleted them all. I then ran the installer and the new installation is working OK. I guess one of the files left behind by an old installation was incompatable with the new version. I hope this helps someone.

11-27-2006 10:43 PM

Posted by:
Don

Find more posts by Don

Same problem

I have the same problem with lag, but I might be able to shed some light to help tech support. It only happens with big queues, and it happens every time iGetter finishes downloading a file and updates the finder--and it takes a LONG time to do so. So the UI hangs and can continue to stay hung while multiple files keep getting written to the drive. IE, as soon as one file is updated in the finder and frees up the iGetter UI, another is already hanging up the UI. So if you watch your download folder, you can see that iGetter is working, albeit more slowly than it should be, but it could be a minute before the UI unlocks and lets you access the program. Of course, that might only last a few seconds before it hangs again.

So my conclusion is that the hand has something to do with the way iGetter finishes downloads and updates the file in the finder (IE, changes the file type from download to whatever file type it is)--and it happens only with big queues. So maybe it's hanging somewhere in the subroutine that compares file names and types. . .

I have tried following the advice here in this column (setting the max segments to 3 and the max downloads to 3. it still doesn't help.

Igetter is a great tool, and would probably be perfect if it wasn't for this one big glitch.

All times are CT (US)    Post New Thread     Post A Reply
Forum Jump:
< Last Thread     Next Thread >



| Home | News | iGetter | Downloads | Forums |

| Privacy Policy | Contact us |

All contents of these forums are copyright © 2001-2016 Presenta Ltd. All rights reserved.
Forums are moderated by Presenta Ltd.

Powered by: vBulletin Lite Version 1.0.0 Lite
Copyright © Jelsoft Enterprises Limited 2000.